Помогите c С#! На основании алгоритмов напишите программу поиска максимального элемента в массиве из 10 элементов.

Помогите c С#! На основании алгоритмов напишите программу поиска максимального элемента в массиве из 10 элементов.
Гость
Ответ(ы) на вопрос:
Гость
using System; class Program {         static void Main(string[] args)         {             int n=10;             int[] a = new int[n];             int max;             Random r = new Random();             Console.WriteLine("Массив a:");             for (int i = 0; i < n; i++)             {                 a[i] = r.Next(41)-20;                 Console.Write("{0,5}", a[i]);             }             Console.WriteLine();             max = a[0];             for (int i = 1; i < n; i++)                 if (a[i]>max) max = a[i];             Console.Write("max = {0}", max);             Console.ReadKey();         } } Пример: Массив a:  3 7 17 -11 9 20 7 3 -15 10 max = 20
Не нашли ответ?
Ответить на вопрос
Похожие вопросы