Помогите исправить ошибки и написать блок-схему. Задание: Имеется массив А из N произвольных чисел, среди которых есть положительные, отрицательные и равные нулю. Используя оператор цикла, составить программу, вычислить количес...
Помогите исправить ошибки и написать блок-схему. Задание: Имеется массив А из N произвольных чисел, среди которых есть положительные, отрицательные и равные нулю. Используя оператор цикла, составить программу, вычислить количество положительных и нулевых и сумму отрицательных. Листинг программы: Program Massiv; Const n=10; Var A:array [1..4] of integer; I, c, c2, c3: integer; Begin For i=1 to N do begin Readln (a[i]); If (a[i]=0 then inc(c) Else if ([ai]<0) then inc(c2) Else inc (c3); End; Writeln (`нулевые:`,c); Writeln (`отрицательные:`,c2); Writeln (`положительные:`,c3); End.
Ответ(ы) на вопрос:
uses crt; var i,d,o,n,m:integer;
a:array[1..100] of integer;
begin
readln(n);
randomize;
for i:=1 to n do a[i]:=random(101)-50;
for i:=1 to n do begin
if a[i] < 0 then o:=o+a[i]
else inc(d);
if a[i] = 0 then inc(m);
end;
for i:=1 to n do write(a[i],' ');
writeln;
writeln('null = ',m);
writeln('otr = ',o);
writeln('pol = ',d);
readln; end.
Не нашли ответ?
Похожие вопросы