Помогите написать программу на C#! Даны координаты точки А(х1,у1). Определить, принадлежит ли эта точка какой-нибудь оси координат. Если да, то какой.

Помогите написать программу на C#! Даны координаты точки А(х1,у1). Определить, принадлежит ли эта точка какой-нибудь оси координат. Если да, то какой.
Гость
Ответ(ы) на вопрос:
Гость
using System; class Program {     static void Main()     {         for(var x=-2;x<=2;x++){             for(var y=-2;y<=2;y++){                 IsPointOnAxis(x, y);             }         }         Console.ReadKey();     }     static void IsPointOnAxis(int x, int y){         Console.WriteLine("Point  = {0}; {1}", x, y);         if (x*y != 0){             Console.WriteLine("Point not on axis");             return;         }         if (x == 0){             Console.WriteLine("Point is on axis Ox");         }else if (y == 0){             Console.WriteLine("Point is on axis Oy");         }     } }
Не нашли ответ?
Ответить на вопрос
Похожие вопросы