Помогите написать программу на C# Написать программу, удаляющую из записи числа все чётные цифры.
Помогите написать программу на C#
Написать программу, удаляющую из записи числа все чётные цифры.
Ответ(ы) на вопрос:
static class Program
{
public static IEnumerable Digits(this uint X, bool Reverse = true)
{
do { yield return X % 10; } while ((X /= 10) != 0);
}
static uint ToUnsignedInt32(this IEnumerable Digits)
{
return Digits.Reverse().Aggregate((a, d) => a * 10 + d);
}
static void Main()
{
Console.WriteLine(
uint.Parse(Console.ReadLine())
.Digits()
.Where(d => d % 2 == 1)
.ToUnsignedInt32());
Console.ReadKey();
}
}
Не нашли ответ?
Похожие вопросы