Помогите написать программу на паскале Дан целочисленный массив из 20 элементов.

Помогите написать программу на паскале Дан целочисленный массив из 20 элементов.Элементы массива могут принимать целые значения от -10000 до 10000 включительно. Опишите на естественном языке или на одном из языков программирования алгоритм, позволяющий найти и вывести количество пар элементов массива, сумма которых четна и положительна. Под парой подразумевается два подряд идущих элемента массива.
Гость
Ответ(ы) на вопрос:
Гость
Program gt; var a:array[1..20]of longint; i,h:longint; begin for i:=1 to 20 do read(a[i]); for i:=1 to 19 do if((a[i]+a[i+1]>0)and((a[i]+a[i+1])mod 2=0))then h:=h+1; writeln(h); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы