Помогите написать программу по информатике! Дана непустая последовательность целых чисел, оканчивающаяся отрицательным числом. Верно ли, что все элементы последовательности равны между собой?
Помогите написать программу по информатике! Дана непустая последовательность целых чисел, оканчивающаяся отрицательным числом. Верно ли, что все элементы последовательности равны между собой?
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Длина последовательности: ');
var a:=(SeqRandom(n-1,0,1)+(-1)).ToArray; // последовательность 0 и 1
a.Println;
if a.Where(x->x>=0).Distinct.Count>1 then
Writeln('Есть отличающиеся элементы')
else Writeln('Все элементы равны')
end.
Примеры
Длина последовательности: 4
1 1 1 -1
Все элементы равны
Длина последовательности: 5
0 1 1 0 -1
Есть отличающиеся элементы
Не нашли ответ?
Похожие вопросы