Помогите написать программу си++ вот условие задачи: задан массив целых чисел. Отс?
Помогите написать программу си++ вот условие задачи: задан массив целых чисел. Отс??ртировать четные элементы массива по возрастанию, а нечетные по убыванию. Очень срочно нужно
Ответ(ы) на вопрос:
//Dev-C++ 5.11
#include <iostream>
using namespace std;
int main(void)
{const int n=6;
int arr[n],c;
for(int i=0;i<n;i++)
cin>>arr[i];
for(int i=0;i<n-1;i++)
for(int j=i+1;j<n;j++)
if(arr[i]>arr[j] && arr[i]%2==0 && arr[j]%2==0)
{c=arr[i];
arr[i]=arr[j];
arr[j]=c;} for(int i=0;i<n-1;i++) for(int j=i+1;j<n;j++) if(arr[i]<arr[j] && arr[i]%2!=0 && arr[j]%2!=0) {c=arr[i];
arr[i]=arr[j];
arr[j]=c;} cout<<"Array"<<endl; for(int i=0;i<n;i++) cout<<arr[i]<<" "; return 0;} Пример ввода: 2 6 4 1 5 3 Пример вывода: Array 2 4 6 5 3 1
int arr[n],c;
for(int i=0;i<n;i++)
cin>>arr[i];
for(int i=0;i<n-1;i++)
for(int j=i+1;j<n;j++)
if(arr[i]>arr[j] && arr[i]%2==0 && arr[j]%2==0)
{c=arr[i];
arr[i]=arr[j];
arr[j]=c;} for(int i=0;i<n-1;i++) for(int j=i+1;j<n;j++) if(arr[i]<arr[j] && arr[i]%2!=0 && arr[j]%2!=0) {c=arr[i];
arr[i]=arr[j];
arr[j]=c;} cout<<"Array"<<endl; for(int i=0;i<n;i++) cout<<arr[i]<<" "; return 0;} Пример ввода: 2 6 4 1 5 3 Пример вывода: Array 2 4 6 5 3 1
Не нашли ответ?
Похожие вопросы