Помогите написать программу в паскале Дан целочисленный массив. Он заполняется при запуске программы: сначала запросить число элементов (n от 1 до 40), затем - элементы – целые числа в интервале от -500 до 500. a. количество ...

Помогите написать программу в паскале Дан целочисленный массив. Он заполняется при запуске программы: сначала запросить число элементов (n от 1 до 40), затем - элементы – целые числа в интервале от -500 до 500. a. количество чисел, оканчивающихся на 3; b. найти среднее арифметическое всех положительных элементов массива, которые кратны первому элементу (делятся нацело на первый элемент). Гарантируется, что первый элемент массива положительный. c. наибольший отрицательный элемент, который делится на 3.
Гость
Ответ(ы) на вопрос:
Гость
var   a:array[1..40] of integer;   i,n,k3,k,s,a3:integer; begin   Write('n='); Read(n);   for i:=1 to n do Read(a[i]);   k3:=0; {a}   s:=0; k:=0; {b}   a3:=-1000; {c}   for i:=1 to n do begin     if a[i] mod 10=3 then Inc(k); {a}     if (a[i]>0) and (a[i] mod a[1]=0) then begin {b}       s:=s+a[i]; Inc(k)       end;     if (a[i]<0) and (a[i]>a3) and (a[i] mod 3=0) then a3:=a[i]; {c}     end;   Writeln('Кол-во чисел. оканчивающихся на 3: ',k3); {a}   Writeln('Среднее арифметическое по условию: ',s/k:0:3); {b}   if a3<>1000 then Writeln('Наибольший отрицательный, кратный 3: ',a3) {c}   else Writeln('Нет отрицательных элементов, кратных 3') end. Для решения конкретного пункта выбирать только операторы, помеченные этим пунктом, Например, {a} для а)
Не нашли ответ?
Ответить на вопрос
Похожие вопросы