Помогите написать программу в паскале!Очень надо!Задана последовательность целых чисел,количество которых не превосходит 100.Требуется определить за один проход элемент с максимальным значением,а также число его повторений в по...

Помогите написать программу в паскале!Очень надо! Задана последовательность целых чисел,количество которых не превосходит 100.Требуется определить за один проход элемент с максимальным значением,а также число его повторений в последовательности.
Гость
Ответ(ы) на вопрос:
Гость
var   i,k,max:integer;   a:array[1..100]of integer; begin writeln('Исходная последовательность: '); for i:=1 to 100 do   begin   a[i]:=random(200);   write(a[i],' ');   if a[i]>max then     begin     max:=a[i];     k:=1;     end;   if a[i]=max then     k:=k+1;   end; writeln; writeln('Максимальное значение: ',max); writeln('Число повторений: ',k) end.
Гость
program maxof; var ar: array [1..100] of integer; i, j, posl: shortint; max: integer; begin readln(i); for j:=1 to i do begin readln(ar[j]); end; max:=ar[1]; posl:=1; for j:=2 to i do begin if max = ar[j] then inc(posl); if max < ar[j] then begin posl:=1; max:=ar[j] end;  end; writeln(max, ' x', posl); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы