Помогите написать программу в с++ Составить программу определения значений указанных ниже линейного массива.Выполнить программу для длины массива N=8 Сумма обратных величин не
Помогите написать программу в с++ Составить программу определения значений указанных ниже линейного массива.Выполнить программу для длины массива N=8 Сумма обратных величин не нулевых элементов массива
Ответ(ы) на вопрос:
Гость
#include <iostream> using namespace std; const int N = 8; //длина массива double s = 0; //начальное значение суммы double mas[N]; //объявляем статический массив длины N int main() { //вводим элементы массива for(int i = 0; i < N; ++i) { cin >> mas[i]; } //пробегаемся по элементам массива for(int i = 0; i < N; ++i) { if(mas[i] != 0.0) //если элемент массива не равен 0 s += 1. / mas[i]; //прибавляем значение обратного элемента к итоговой сумме } cout << s; //вывод суммы на экран return 0; }
Не нашли ответ?
Похожие вопросы