⚠️⚠️⚠️⚠️⚠️⚠️ПОМОГИТЕ ⚠️⚠️⚠️⚠️⚠️⚠️ Напишите программу в которой есть массив созданный по формуле: а[i]:=2x+2i Где x это число которое вводит пользователь с клавиатуры и кол-во чисел в массиве n тоже с клавиатуры

⚠️⚠️⚠️⚠️⚠️⚠️ПОМОГИТЕ ⚠️⚠️⚠️⚠️⚠️⚠️ Напишите программу в которой есть массив созданный по формуле: а[i]:=2x+2i Где x это число которое вводит пользователь с клавиатуры и кол-во чисел в массиве n тоже с клавиатуры
Гость
Ответ(ы) на вопрос:
Гость
//PascalABC.Net 3.2 begin var a:=ReadArrInteger ('Вводите: ', readinteger('n =')); for var i:=0 to length(a)-1 do a[i]:=2*a[i]+2*(i+1); a.Print end.
Гость
var n,x,i:integer; a:array of integer; begin write('n = '); readln(n); write('x = '); readln(x); SetLength(a,n); for i:=0 to n-1 do a[i]:=2*x+2*i ; for i:=0 to n-1 do write(a[i],' '); writeln; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы