Помогите не могу написать программу на C# Напишите программу которая определяет ?
Помогите не могу написать программу на C#
Напишите программу которая определяет ?? заданном числе заданную цифру.\
Цифра это числа от 0 до 9
Ответ(ы) на вопрос:
Гость
Using System;
//Напишите программу которая определяет в заданном числе заданную цифру.
//Цифра это числа от 0 до 9
namespace NoNamespace {
internal class Program {
private static void Main() {
Console.WriteLine(IsDigitInNumber(123.8, 2));
Console.WriteLine(IsDigitInNumber(1, 1));
Console.WriteLine(IsDigitInNumber(103.28, 2));
Console.ReadLine();
}
private static int IsDigitInNumber(double number, uint digit) {
if (0 > digit || digit > 9)
throw new Exception("Не верный формат цифры");
var n = number.ToString().IndexOf(digit.ToString());
var p = number.ToString().IndexOf(".");
//Console.WriteLine($"number = {number} digit = {digit} n = {n} p = {p} A = {p-n}");
return p-n;
}
}
}
Не нашли ответ?
Похожие вопросы