Помогите нужно составить программу,которая формирует массив с 16 случайных целых чисел от -20 до 20 и: находит элементы с нулевыми значениями
Помогите нужно составить программу,которая формирует массив с 16 случайных целых чисел от -20 до 20 и: находит элементы с нулевыми значениями
Ответ(ы) на вопрос:
Не понял смысл задачи.
Написал, вывод номера элементов равных 0.
#include #include
int main(void){ int mas[16]; //массив со случайными числами int i; //счетчик
//заполнение массива случайными числами for(i=0; i<16; i++) mas[i] = -20+rand()%20; printf("ishodny massiv"); for(i=0;i<16;i++) printf("%d,",mas[i]); printf("\n");
printf("nomera elementov massiva ravnih nulu"); for(i=0;i<16;i++) if (mas[i]==0) printf("%d",i+1);
return 0;}
Не нашли ответ?
Похожие вопросы