Помогите плиз написать программу в паскале Найти сумму чётных натуральных чисел в промежутке от n1 до n2. Pascal ABC.

Помогите плиз написать программу в паскале Найти сумму чётных натуральных чисел в промежутке от n1 до n2. Pascal ABC.
Гость
Ответ(ы) на вопрос:
Гость
1. "Школьное" решение // PascalABC.Net 3.0, сборка 1064 var   i,n1,n2:integer;   s:longint; begin   Write('Введите интервал для вычисления суммы: '); Read(n1,n2);   s:=0;   if n1 mod 2 = 0 then i:=n1 else i:=n1+1;   while i<=n2 do begin s:=s+i; i:=i+2 end;   Writeln('Сумма четных чисел в интервале равна ',s) end. Тестовое решение: Введите интервал для вычисления суммы: 7 14 Сумма четных чисел в интервале равна 44 2. Современное решение // PascalABC.Net 3.0, сборка 1064 var   n1,n2:integer; begin   Write('Введите интервал для вычисления суммы: '); Read(n1,n2);   if Odd(n1) then Inc(n1);   Writeln('Сумма четных чисел в интервале равна ',Range(n1,n2,2).Sum); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы