ПОМОГИТЕ ПЛИЗ! СРОЧНО НАДО! 1. Составьте программу, решающую следующую задачу: С кондитерской фабрики отгружают конфеты в коробках по 10 кг, 5 кг и 1 кг. Какое наименьшее количество (K) коробок потребуется для перевозки N килог...

ПОМОГИТЕ ПЛИЗ! СРОЧНО НАДО! 1. Составьте программу, решающую следующую задачу: С кондитерской фабрики отгружают конфеты в коробках по 10 кг, 5 кг и 1 кг. Какое наименьшее количество (K) коробок потребуется для перевозки N килограмм конфет? Вводимое N Выводимое K 456 47 150 15 153 18 298 33 2. Для заданного числа суток определить количество часов, минут и секунд. Вводимое количество суток Выводимое количество часов, минут, секунд 7 суток = 168 часов = 10080 минут = 604800 секунд 1 сутки = 24 часов = 1440 минут = 86400 секунд 10 суток = 240 часов = 14400 минут = 864000 секунд 2 суток = 48 часов = 2880 минут = 172800 секунд
Гость
Ответ(ы) на вопрос:
Гость
1. var n, k: integer; begin   read(n);   k := n div 10;   n := n mod 10;   k := k + n div 5;   n := n mod 5;   k := k + n;   writeln(k); end. 2. var n: integer; begin   read(n);   writeln(n, ' суток = ', 24 * n, ' часов = ', 1440 * n, ' минут = ', 86400 * n, ' секунд'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы