Помогите пожалуйста!!Буду очень сильно благодарен!! На языке PascalABC.Net или TurboPascal: 1) Разработать программу циклической структурой,используя цикл с параметром. Да

Помогите пожалуйста!!Буду очень сильно благодарен!! На языке PascalABC.Net или TurboPascal: 1) Разработать программу циклической структурой,используя цикл с параметром. Да но действительное число х, натуральное число n. Написать программу, которая вычисляет сумму последовательности, заданной формулы x^1/1!+x^2/2!+x^3/3!+...+x^n/n! 2) Разработать программу циклической структурой в соответствии с предложенным вариантом, используя цикл с предусловием. Дано действительное число х, натуральное число n. Написать программу, которая вычисляет сумму последовательности, заданной формулы x^1/1!+x^2/2!+x^3/3!+...+x^n/n! 3)Определить значение z = max (a, 2b) • max (2a-b, b),где max (x, y) есть максимальное из чисел х, у. При peшении задачи определить и использовать функцию max.Выполнить отладку программы с заходом в каждую из подпрограмм.
Гость
Ответ(ы) на вопрос:
Гость
//Pascal ABC.NET 3.1 сборка 1219 //1 Var n,i:integer; x,y:real; function fact(x:integer):int64; begin if x>1 then fact:=fact(x-1)*x else fact:=1; end; begin read(x,n); i:=1; n:=n+1; repeat y:=y+power(x,i)/fact(i); inc(i); until n=i; writeln(y); end. //2 Var n,i:integer; x,y:real; function fact(x:integer):int64; begin if x>1 then fact:=fact(x-1)*x else fact:=1; end; begin read(x,n); i:=1; n:=n+1; while i<>n do begin y:=y+power(x,i)/fact(i); inc(i); end; writeln(y); end. //3 Var a,b,z:integer; function max(a,b:integer):integer; begin if a>b then max:=a else max:=b; end; begin read(a,b); z:=max(a,2*b)*max(2*a-b,b); writeln(z); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы