Помогите пожалуйста написать программу си++ задан массив целых чисел вычислить ?
Помогите пожалуйста написать программу си++
задан массив целых чисел вычислить ??умму отрицательных элементов этого массива и определить их количество
Ответ(ы) на вопрос:
#include <iostream>
using namespace std;
int main()
{
int n, sum,howmuch;
sum = howmuch = 0;
cout << "Введите количество элементов массива" << endl;
cin >> n;
int a[n];
for(int i =0; i < n; i++){
cout << "Заполните массив" << endl;
cin >> a[i];
}
for(int i = 0; i < n; i++){
if (a[i] < 0)
{
howmuch++;
sum += a[i];
}
}
cout << "Сумма отрицательных элементов массива:" << sum << endl;
cout <<"Количество отрицательных объектов массива" << howmuch << endl;
return 0;
}
Не нашли ответ?
Похожие вопросы