Помогите, пожалуйста Нужно написать программу позволяющую вводить оценки учени?

Помогите, пожалуйста Нужно написать программу позволяющую вводить оценки учени??ов в массиве. Из чего должна состоять: 1) Количество учеников в классе 2) На основе запросить оценки каждого ученика 3) Должна вывести количество пятерок, четверок, троек и двоек 3) Успеваемость в процентах (количество оценок (положительных 3,4,5)/количество учеников умножить на 100 процентов.
Гость
Ответ(ы) на вопрос:
Гость
//Pascal ABC.NET v3.1 сборка 1172 var   ar: array of integer;   n, k2, k3, k4, k5, i: integer;   r: real; begin   write('Сколько учеников?');   readln(n);   setlength(ar, n);   writeln('Введите оценки:');   for i := 0 to n - 1 do   begin     readln(ar[i]);     case ar[i] of       2: inc(k2);       3: inc(k3);       4: inc(k4);       5: inc(k5);     else       writeln('Не оценка');       exit;     end;   end;   writeln('2:', k2);   writeln('3:', k3);   writeln('4:', k4);   writeln('5:', k5);   write('Успеваемость=', (k3 + k4 + k5) / n * 100:0:1); end. Пример ввода: Сколько учеников?6 Введите оценки: 2 2 3 4 5 5 Пример вывода: 2:2 3:1 4:1 5:2 Успеваемость=66.7
Не нашли ответ?
Ответить на вопрос
Похожие вопросы