Помогите, пожалуйста, написать программу для ABC паскаль. Нужно сделать так, чтобы программа в ответе выдала xoxoxoxoxo, но при этом мы указываем сколько должно быть столбцов, сколько рядов. Должна получиться шахматная доска. 1...
Помогите, пожалуйста, написать программу для ABC паскаль.
Нужно сделать так, чтобы программа в ответе выдала xoxoxoxoxo, но при этом мы указываем сколько должно быть столбцов, сколько рядов. Должна получиться шахматная доска. 10 класс
Program Ksenia
Var..... и т.д. Пожалуйста!!!! 39 баллов! Больше нет(
Ответ(ы) на вопрос:
var n,m,i,j:integer;
begin
write('n = ');
readln(n);
write('m = ');
readln(m);
for i:=1 to n div 2 do
begin
for j:=1 to m div 2 do write('xo');
if m mod 2 = 1 then write('x');
writeln;
for j:=1 to m div 2 do write('ox');
if m mod 2 = 1 then write('o');
writeln;
end;
if n mod 2 = 1 then
begin
for j:=1 to m div 2 do write('xo');
if m mod 2 = 1 then write('x');
writeln;
end;
end.
Пример:
n = 3
m = 5
xoxox
oxoxo
xoxox
Не нашли ответ?
Похожие вопросы