Помогите пожалуйста Написать программу, которая суммирует N отрицательных четных чисел из вводимых с клавиатуры чисел, при вводе N=0 выход из программы.
Помогите пожалуйста Написать программу, которая суммирует N отрицательных четных чисел из вводимых с клавиатуры чисел, при вводе N=0 выход из программы.
Ответ(ы) на вопрос:
CLS b: INPUT n IF n<0 OR INT(n)<>n THEN GOTO b IF n=0 THEN END DIM a(n) FOR i = 1 TO n a: INPUT a(n) IF a(n) >= 0 OR INT (a(n)/2)<>(a(n)/2) THEN GOTO a s=s+a(n) NEXT i PRINT s
Program ilnur17;
uses crt;
var
n,sum,temp: integer;
begin
write('Введите число ');
readln(n);
if n<>0 then
begin
sum:=0;
writeln('*** alphaues is thinking... ***');
writeln('*** OK ***');
while n>=1 do
begin
write('Введите следующее число ');
readln(temp);
if (temp<0) and (temp mod 2 = 0 ) then
sum := sum + temp;
n:=n-1
end;
end
else
writeln('Вы ввели 0 - выход из программы');
writeln('Cуммa отрицательных четных чисел равна ',sum);
end.
Не нашли ответ?
Похожие вопросы