ПОМОГИТЕ ПОЖАЛУЙСТА НАПИСАТЬ ПРОГРАММУ НА ПАСКАЛЕ Переведите натуральное число из двоичной системы в десятичную (в двоичном числе не более 10 цифр). Входные данные Вводится натуральное число, записанное в двоичной системе. Выхо...

ПОМОГИТЕ ПОЖАЛУЙСТА НАПИСАТЬ ПРОГРАММУ НА ПАСКАЛЕ Переведите натуральное число из двоичной системы в десятичную (в двоичном числе не более 10 цифр). Входные данные Вводится натуральное число, записанное в двоичной системе. Выходные данные Выведите число, записанное в десятичной системе. Примеры входные данные 1 выходные данные 1 входные данные 1001 выходные данные 9
Гость
Ответ(ы) на вопрос:
Гость
{by Puporev} const digit : string[16] = '0123456789ABCDEF'; Function ToDec(n:string;r:byte) : longint; var m,i:longint; begin   m:=0;   for i:=1 to length(n) do   m:=m*r+pos(n[i],digit)-1;   ToDec:=m; end; Var S : String; Begin   Readln(S);   Writeln(ToDec(S,2)); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы