ПОМОГИТЕ, ПОЖАЛУЙСТА, НАПИСАТЬ ПРОГРАММУ Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа...
ПОМОГИТЕ, ПОЖАЛУЙСТА, НАПИСАТЬ ПРОГРАММУ
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 3.
Ответ(ы) на вопрос:
Гость
var
d, s, i, n: integer;
begin
readln(n);
readln(d);
for i := 1 to n do
begin
readln(d);
if d mod 3 = 0 then s := s + d;
end;
writeln('s = ', s);
end.
Не нашли ответ?
Похожие вопросы