Помогите пожалуйста написать программу по информатике: Найти произведение положительных, сумму и количество отрицательных из 10 введенных целых чисел.

Помогите пожалуйста написать программу по информатике: Найти произведение положительных, сумму и количество отрицательных из 10 введенных целых чисел.
Гость
Ответ(ы) на вопрос:
Гость
 program ex;  var a,k,s,pr,i:integer;mas:array [0..10] of integer;  begin  pr:=1;  for i:=1 to 10 do    readln(mas[i]);   for i:=1 to 10 do   begin     if mas[i]>0 then      pr:=pr*mas[i]     else      s:=s+mas[i];   end;   for i:=1 to 10 do    begin     if mas[i]<0 then       k:=k+1;     end;  writeln('Произведение=',pr);  writeln('Сумма=',s);  writeln('Количество=',k)  end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы