Помогите пожалуйста написать программу в Паскале: Получить в убывающем порядке все двузначные числа, в десятичной записи которых нет цифры 5.
Помогите пожалуйста написать программу в Паскале:
Получить в убывающем порядке все двузначные числа, в десятичной записи которых нет цифры 5.
Ответ(ы) на вопрос:
program dig_2_no5_downto;
var
i,a,b: integer;
begin
i := 99;
while i >= 10 do
begin
a := i div 10;
b := i mod 10;
if (a <> 5) and (b <> 5) then
write(i, ' ');
i := i - 1;
end;
end.
var
i: integer;
begin
for i := 99 downto 10 do
if (i mod 10 <> 5) and (i div 10 <> 5) then
write(i, ' ');
end.
Не нашли ответ?
Похожие вопросы