Помогите пожалуйста. Нужно написать программу в "Паскале" для перевода из любых систем исчисления в десятичную.
Помогите пожалуйста.
Нужно написать программу в "Паскале" для перевода из любых систем исчисления в десятичную.
Ответ(ы) на вопрос:
var
n, k, i: integer;
s: string;
begin
write('Введите число: ');
read(s);
write('Введите исходную систему счисления: ');
read(k);
for i := 1 to length(s) do
n := n * k + ord(s[i]) - 48;
write(s, '(2) = ', n, '(10)');
end.
Пример работы программы:
Введите число: 101000111000111
Введите исходную систему счисления: 2
101000111000111(2) = 20935(10)
Не нашли ответ?
Похожие вопросы