Помогите пожалуйста. Очень прошу) Заранее благодарна) Дана программа:Program p1;var a:integer.beginwrite('Введите целое число:');readln(a);if(a больше =100) and (a меньше 1000)then write(' Да')                                  ...

Помогите пожалуйста. Очень прошу) Заранее благодарна)  Дана программа: Program p1; var a:integer. begin write('Введите целое число:'); readln(a); if(a>=100) and (a<1000)then write(' Да')                                           else write(' Нет'); End. 1.Запишите, что будет выведено на экране в результате выполнения данной в п.1 программы. при=-2, при а=123. 2. Внести данную программу изменения таким образом, чтобы программа определяла, удовлетворяет ли данное вещественное число а неравенству -14,5 < a <_ 18, 3. Даны целые числа a и b. Составьте программу, определяющую, есть ли среди них  хотя бы одно, не равное нулю. 4. Ввести три целых числа. Если ни одно из чисел не является чётным, то вывестина экран их произведение.  Тема с Packal ABC.
Гость
Ответ(ы) на вопрос:
Гость
1. Нет, Да 2. Program p2; var a:integer. begin write('Введите целое число:'); readln(a); if(a>-14.5) and (a<=18)then write(' Да') else write(' Нет'); End. 3.  Program p3; var a,b:integer. begin write('Введите числа:'); readln(a,b); if(a<>0) or (b<>0)then write(' Есть число, не равное нулю') else write('Нет чисел, равных 0 '); End. 4. Program p4; var a,b,c:integer. begin write('Введите числа:'); readln(a,b,c); if(a mod 2<>0) and (b mod 2<>0) and (c mod 2<>0)then write(A*B*C); End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы