Помогите , пожалуйста, с решением двух задач ! Очень срочно. Нужно написать программу на Паскаль, заранее, спасибо!)В двумерном массиве 5 x 5, заполненный случайными числами, найти количество положительных элементовДан двумерны...
Помогите , пожалуйста, с решением двух задач ! Очень срочно. Нужно написать программу на Паскаль, заранее, спасибо!)
В двумерном массиве 5 x 5, заполненный случайными числами, найти количество положительных элементовДан двумерный массив A[n,n]. Сформировать одномерный массив В, состоящий только их элементов главной диагонали.
Ответ(ы) на вопрос:
Гость
var a: array[1..5,1..5] of integer;
pol,i,j:integer;
begin
randomize;
for i:=1 to 5 do
for j:=1 to 5 do a[i,j]:=random(100)-50;
for i:=1 to 5 do
for j:=1 to 5 do if a[i,j]>0 then inc(pol);
write(pol);
end.
Не нашли ответ?
Похожие вопросы