Помогите, пожалуйста!   Составить программу, которая определяет, являются ли разные точки с координатами (X1,Y1) и (X2, Y2) симметричными относительно осей координат или начала координат.Программу составить двумя способами:С ис...

Помогите, пожалуйста!   Составить программу, которая определяет, являются ли разные точки с координатами (X1,Y1) и (X2, Y2) симметричными относительно осей координат или начала координат. Программу составить двумя способами: С использованием составных условий. Без использование составных условий. Проверить правильность программ для следующих значений параметров: А) X1= -1, Y1=6, X2=1, Y2=6. Б) X1=6, Y1=7, X2=1, Y2=6.
Гость
Ответ(ы) на вопрос:
Гость
а на языке каком нужно написать си или паскаль ?
Гость
С использованием составных условий: Program Type1; Var X1, Y1, X2, Y2: Integer; BeginWriteLn('X1 = '); ReadLn(X1); WriteLn('Y1 = '); ReadLn(Y1); WriteLn('X2 = '); ReadLn(X2); WriteLn('Y2 = '); ReadLn(Y2); If (X1 = -X2) And (Y1 = -Y2) Then WriteLn('Точки симметричны относительно начала координат') Else If (X1 = -X2) And (Y1 = Y2) Then WriteLn('Точки симметричны относительно оси Y') Else If (X1 = X2) And (Y1 = -Y2) Then WriteLn('Точки симметричны относительно оси X') Else WriteLn('Точки не симметричны'); ReadLn; End. Без использования составных условий: Program Type2; Var X1, Y1, X2, Y2: Integer; Begin WriteLn('X1 = '); ReadLn(X1); WriteLn('Y1 = '); ReadLn(Y1); WriteLn('X2 = '); ReadLn(X2); WriteLn('Y2 = '); ReadLn(Y2); If (X1 + X2 = 0) And (Y1 + Y2 = 0) Then WriteLn('Точки симметричны относительно начала координат') Else If (X1 + X2 = 0) And (Abs(Y1) - Abs(Y2) = 0) Then WriteLn('Точки симметричны относительно оси Y') Else If (Abs(X1) - Abs(X2) = 0) And (Y1 + Y2 = 0) Then WriteLn('Точки симметричны относительно оси X') Else WriteLn('Точки не симметричны'); ReadLn; End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы