Помогите ПОЖАЛУЙСТА составить программу паскаль которая будет вычислять периметр и площадь прямоугольника. и программу которая будет вычислять косинус углов треугольника а,в,с

Помогите ПОЖАЛУЙСТА составить программу паскаль которая будет вычислять периметр и площадь прямоугольника. и программу которая будет вычислять косинус углов треугольника а,в,с
Гость
Ответ(ы) на вопрос:
Гость
Периметр прямоугольника: P=2(a+b). Площадь: S=ab Косинусы углов в треугольнике: cosA=(b²+c²-a²)/(2bc); cosB=(a²+c²-b²)/(2ac); cosC=(a²+b²-c²)/(2ab) var   a,b:real; begin   Write('Введите a,b: ');   Read(a,b);   Write('P=',2*(a+b),', S=',a*b) end. Тестовое решение Введите a,b: 12.2 8 P=40.4, S=97.6 var   a,b,c,cosA,cosB,cosC:real; begin   Write('Введите a,b,c: ');   Read(a,b,c);   cosA:=(b*b+c*c-a*a)/(2*b*c);   cosB:=(a*a+c*c-b*b)/(2*a*c);   cosC:=(a*a+b*b-c*c)/(2*a*b);   Write('cosA=',cosA,', cosB=',cosB,', cosC=',cosC) end. Тестовое решение Введите a,b,c: 15.3 8 14.2 cosA=0.138864436619718, cosB=0.855495719414526, cosC=0.393995098039216
Не нашли ответ?
Ответить на вопрос
Похожие вопросы