Помогите, пожалуйста, составить программу в паскаль авс. Даны вектора a, b. Элементы матрицы S=(sij) m*n вычисляются по формуле sij= ai*bj. Найти матрицу S и сумму элементов ее k-ого столбца. Вектор a =(2; -7.1; 3.2; -5.4; 6.9...

Помогите, пожалуйста, составить программу в паскаль авс. Даны вектора a, b. Элементы матрицы S=(sij) m*n вычисляются по формуле sij= ai*bj. Найти матрицу S и сумму элементов ее k-ого столбца. Вектор a =(2; -7.1; 3.2; -5.4; 6.9), вектор b = (8.1; 3.2; -6.4; -3.5) , k=3
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.0, сборка 1073 const   m=5;   n=4;   a:array[1..m] of real=(2,-7.1,3.2,-5.4,6.9);   b:array[1..n] of real=(8.1,3.2,-6.4,-3.5);   k=3; var   i,j:integer;   sk:real;   s:array[1..m,1..n] of real; begin   Writeln('Массив S');   for i:=1 to m do begin     for j:=1 to n do begin       s[i,j]:=a[i]*b[j];       Write(s[i,j]:7:2)     end;     Writeln   end;   sk:=0;   for i:=1 to m do sk:=sk+s[i,k];   Writeln('Сумма элементов столбца ',k,' равна ',sk) end. Результат выполнения программы: Массив S   16.20   6.40 -12.80  -7.00  -57.51 -22.72  45.44  24.85   25.92  10.24 -20.48 -11.20  -43.74 -17.28  34.56  18.90   55.89  22.08 -44.16 -24.15 Сумма элементов столбца 3 равна 2.56
Не нашли ответ?
Ответить на вопрос
Похожие вопросы