Помогите, пожалуйста) Составить программу, выводящую на экран таблицу квадратов натуральных чисел от 1 до n Таблица 1 1 2 4 3 9 4 16 5 25 6 36

Помогите, пожалуйста) Составить программу, выводящую на экран таблицу квадратов натуральных чисел от 1 до n Таблица 1 1 2 4 3 9 4 16 5 25 6 36
Гость
Ответ(ы) на вопрос:
Гость
Program ABC; var a: array [1..100] of integer; i,n ,k: integer; Begin Writete('N =  ');  readln(n); Write('кол-во чисел: '); readln(k); Write('Результат: '); For i:=1 to k do    begin  randomize; a[i]:= random(50)-25; write(a[i], '  '); inc(k); end; i:= 1; k:=0; Writeln; Write('Первые ', n, ' квадратов нат. чисел: '); repeat if a[i]>0 then begin write(sqr(a[i]), '   '); ink(k); end; i:= i+1; until k>n; end.
Гость
var   i,n:integer; begin write('Введите n: ');  readln(n); for i:=1 to n do  writeln(i,' ',i*i); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы