ПОМОГИТЕ ПОЖАЛУЙСТА!!!!!) Составьте программу для нахождения наименьшего натурального числа, куб которого начинается с цифр 2016 выходные данные:3 27

ПОМОГИТЕ ПОЖАЛУЙСТА!!!!!) Составьте программу для нахождения наименьшего натурального числа, куб которого начинается с цифр 2016 выходные данные:3 27
Гость
Ответ(ы) на вопрос:
Гость
var i:integer; c:real; s:string; begin for I:=1 to 99999 do begin c:=power(I,3); s:=c.tostring; if (s.length>3)and(s[1]='2')and(s[2]='0')and(s[3]='1')and(s[4]='6')then begin write(I,'^3=',c); exit; end; end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы