Помогите пожалуйста. Составте программу в Паскаль к задаче. Даны три натуральных числа. Напишите программу определяющую, существует ли треугольник с такими длинами сторон. Если такой треугольник существует, то определите его ти...

Помогите пожалуйста. Составте программу в Паскаль к задаче. Даны три натуральных числа. Напишите программу определяющую, существует ли треугольник с такими длинами сторон. Если такой треугольник существует, то определите его тип (равносторонний, равнобедренный, равносторонний)
Гость
Ответ(ы) на вопрос:
Гость
var a,b,c:integer; begin Write('Введите сторону а: '); Readln(a); Write('Введите сторону b: '); Readln(b); Write('Введите сторону с: '); Readln(c); if (a+b>c) and (a+c>b) and (b+c>a) then  begin write('Данный треугольник существует и является: '); if (a=b) and (b=c) then writeln('равносторонним'); if ((a=b) and (b<>c)) or ((a=c) and (c<>b)) or ((b=c) and (a<>c)) then writeln('равнобедренным'); if (a<>b) and (b<>c) and (a<>c) then writeln('разносторонним'); end else write('Не существует'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы