Помогите пожалуйста) Составьте программу,которая заполняет массив a[1..8] случайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и сумму элементов массива с нечетными значе...
Помогите пожалуйста)
Составьте программу,которая заполняет массив a[1..8] случайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и сумму элементов массива с нечетными значениями.
Ответ(ы) на вопрос:
var a:array[1..8]of integer;
i,k,s:integer;
begin
for i:=1 to 8 do
begin
a[i]:=random(10)+1;
write(a[i],' ');
if a[i] mod 2=0 then k:=k+1
else s:=s+a[i];
end;
writeln;
writeln('kol-vo chet elem:',k,' summa nechet:',s);
end.
Не нашли ответ?
Похожие вопросы