Помогите пожалуйста срочно!!!! Нужно написать программу в Pascal.. Даны названия 3 городов (любых). Вывести на экран самое длинное и самое короткое название.
Помогите пожалуйста срочно!!!! Нужно написать программу в Pascal..
Даны названия 3 городов (любых). Вывести на экран самое длинное и самое короткое название.
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
var a:array[1..3] of string;
var l:array[1..3] of integer;
for var i:=1 to 3 do begin
Write('Город ',i,': '); Readln(a[i]);
l[i]:=Length(a[i])
end;
var imin:=1; var imax:=1;
for var i:=2 to 3 do begin
if l[i]l[imax] then imax:=i
end;
Writeln('Самое длинное название- ',a[imax]);
Writeln('Самое короткое название- ',a[imin])
end.
Тестовое решение
Город 1: Москва
Город 2: Минск
Город 3: Киев
Самое длинное название- Москва
Самое короткое название- Киев
Не нашли ответ?
Похожие вопросы