Помогите пожалуйста, срочно!!Написать программу в Турбо Паскале.Задание:Дан текстовый файл f. Исключить гласные буквы из строк  и поместить результат в файл q.

Помогите пожалуйста, срочно!! Написать программу в Турбо Паскале. Задание:Дан текстовый файл f. Исключить гласные буквы из строк  и поместить результат в файл q.
Гость
Ответ(ы) на вопрос:
Гость
var   f, q: Text;   i: integer;   s: string; begin   Assign(f, 'in.txt');   Reset(f);   Assign(q, 'out.txt');   rewrite(q);   while not EOF(f) do   begin     readln(f, s);     i := 1;     while (i <= length(s)) do     begin       if (upcase(s[i]) in ['А', 'Е', 'Ё', 'И', 'О', 'У', 'Ы', 'Ю', 'Я']) then         delete(s, i, 1);       inc(i);     end;     writeln(q, s);   end;   close(f); close(q); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы