Помогите пожалуйста в информатикой! Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 8. Программа получает на вход натуральные числа, количество введённых чисел н...

Помогите пожалуйста в информатикой! Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 8. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех двузначных чисел, кратных 8.
Гость
Ответ(ы) на вопрос:
Гость
Program pr; uses crt; var chislo, sum, i:integer; Begin sum:=0; for i:=1 to 1000 do    Begin        Writeln('Введите число');        readln(chislo);        if (chislo=0) then break;        if (chislo>30000) then Writeln('число превышает 30000')            else                 Begin                   if ((chislo>9) and (chislo<100) and (chislo mod 8 = 0))                   then sum:=sum+chislo;                 end;     end; Writeln('sum = ', sum); readln; end.
Гость
var a,s:integer; begin read(a); while a<>0 do  begin  if (a>=10)and(a<=99)and(a mod 8 = 0) then s:=s+a;  read(a);  end; writeln(s); end. Пример: 123 16 468 87 12 88 536 0 104
Не нашли ответ?
Ответить на вопрос
Похожие вопросы