Помогите пожалуйста...Напишите программу по которой из текстового файла с именем kvur.txt будут прочитаны три числа: a,b,c - коэффициенты квадратного уравнения затем будут вычислены корни этого уравнения и выведены на экран и в...
Помогите пожалуйста...
Напишите программу по которой из текстового файла с именем kvur.txt будут прочитаны три числа: a,b,c - коэффициенты квадратного уравнения затем будут вычислены корни этого уравнения и выведены на экран и в текстовый файл korni.txt.
на паскале
Ответ(ы) на вопрос:
Если данное уравнение не имеет корней, выведите число 0. Если уравнение имеет один корень, выведите число 1, а затем этот корень. Если уравнение имеет два корня, выведите число 2, а затем два корня в порядке возрастания. Если уравнение имеет бесконечно много корней, выведите число 3.
program gt;
var a,b,c,d,x1,x2,s:real;label 1,2;
begin
read(a,b,c);
if ((a=0)and(b=0)and(c<>0)) then writeln(0);
if(a=0)and(b=0)and(c=0)then writeln(3);
if(a<>0)and(b<>0)and(c<>0)then begin
d:=b*b-4*a*c;
if (d<0)or((a=0)and(b=0)and(c<>0)) then writeln(0);
if d>=0 then begin
x1:=(-b+sqrt(d))/(2*a);
x2:=(-b-sqrt(d))/(2*a);
if x1=x2 then write(1,' ',x1);
if (x1<>x2)and(x1x2)and(x1>x2) then write(2,' ',x2,' ',x1);
end;
end;
if (a=0)and(b<>0)and(c<>0)then begin
x1:=-c/b;
write(1,' ',x1);
end;
if (a<>0)and(b=0)and(c<>0)then begin
if(-c/a>=0) then begin
x2:=sqrt(-c/a);
x1:=-sqrt(-c/a);
if (x1<>x2)and(x1x2)and(x1>x2) then write(2,' ',x2,' ',x1);
end;
if(-c/a<0) then writeln(0);
end;
if (a<>0)and(b<>0)and(c=0)then begin
x1:=0;
x2:=-b/a;
if (x1<>x2)and(x1x2)and(x1>x2) then write(2,' ',x2,' ',x1);
end;
end.
Не нашли ответ?
Похожие вопросы