Помогите пожалуйста,очень надо!!!! .Составить программу. Вывести с клавиатуры целое число,и определить,есть ли в нем повторяющиеся цифры.Программа должна вывести"да" или "нет". Заранее спасибо.
Помогите пожалуйста,очень надо!!!!
.Составить программу.
Вывести с клавиатуры целое число,и определить,есть ли в нем повторяющиеся цифры.Программа должна вывести"да" или "нет".
Заранее спасибо.
Ответ(ы) на вопрос:
Гость
uses crt;
var s:string;
i:integer;
l:boolean;
m:set of char;
begin clrscr;
write('Введите число :');
readln(s); l:=false;
for i:=1 to length(s) do begin
if (m<>m-[s[i]]) then l:=true;
m:=m+[s[i]];
end;
if l then Writeln('Да')
else Writeln('Нет');
end.
Не нашли ответ?
Похожие вопросы