Помогите пожалуйста!!!!Составить программу на Паскале. Ввести 10 целых случайных чисел (в интервале от -10 до 10). Вывести исходный массив. Найти и вывести: 1) минимальный элемент и его индекс; 2) сумму всех элементов массива; ...

Помогите пожалуйста!!!! Составить программу на Паскале. Ввести 10 целых случайных чисел (в интервале от -10 до 10). Вывести исходный массив. Найти и вывести: 1) минимальный элемент и его индекс; 2) сумму всех элементов массива; 3) количество отрицательных элементов. К каждому элементу массива прибавить 1, вывести получившийся массив. Подсказка: 1)random(10)-10 2) положительные: >0 неположительные: <=0 отрицательные: <0 неотрицательные:>=0
Гость
Ответ(ы) на вопрос:
Гость
program gt; var a:array[1..10]of integer; i,min,l,s,k:integer; begin randomize; s:=0; k:=0; for i:=1 to 10 do begin a[i]:=random(20)-10; write(a[i],' '); s:=s+a[i]; if(a[i]<0)then k:=k+1; end; min:=a[1];l:=1; for i:=2 to 10 do if(a[i]<=min)then begin min:=a[i]; l:=i; end; writeln; writeln('сумма элементов массива=',s); writeln('кол-во отрицательных элементов массива=',k); writeln('минимальный элемент массива=',min,' его индекс=',l); for i:=1 to 10 do begin a[i]:=a[i]+1; write(a[i],' '); end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы