Помогите пожалуйста)))Составьте программу, которая формируют массив из шестнадцати случайных целых чисел от -20 до 20 и:а) находит элементы с нулевыми значениями;б) находит индексы четных элементов;
Помогите пожалуйста)))
Составьте программу, которая формируют массив из шестнадцати случайных целых чисел от -20 до 20 и:
а) находит элементы с нулевыми значениями;
б) находит индексы четных элементов;
Ответ(ы) на вопрос:
Гость
var
i: integer;
a: array [1..16] of integer;
begin
randomize;
writeln('Массив: ');
for i := 1 to 16 do
begin
a[i] := random(41) - 20;
write(a[i]:5);
end;
writeln;
writeln('Нулевые элементы: ');
for i := 1 to 16 do
if A[i] = 0 then write(i:5);
writeln;
writeln('Четные элементы: ');
for i := 1 to 16 do
if A[i] mod 2 = 0 then write(i:5);
end.
Не нашли ответ?
Похожие вопросы