Помогите пожалуйста))Составьте программу вычисления суммы элементов четных строк массива Т (6,5) и произведения элементов нечетных строк.

Помогите пожалуйста)) Составьте программу вычисления суммы элементов четных строк массива Т (6,5) и произведения элементов нечетных строк.
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016 // Внимание! Если программа не работает, обновите версию! begin   var a:=MatrRandom(6,5,-50,50); a.Println(4); Writeln;   var res:=new int64[6];   for var i:=0 to 5 do     if i.IsEven then       res[i]:=a.Row(i).Aggregate(int64(1),(x,y)->x*y)     else       res[i]:=a.Row(i).Sum;   Writeln('Результаты:'); res.Println(NewLine) end. Пример  -32  22  12   8 -38   45  22 -12  26  -2  -46  12  19  42  -1   19   5  29 -41 -41   10 -23   2 -19  10   -4  22  15  34  34 Результаты: 2568192 79 440496 -29 87400 101
Не нашли ответ?
Ответить на вопрос
Похожие вопросы