Помогите решить пожалуйста, учитель бьется цветочком!Составьте программу вычисления количества трехзначных чисел-палиндромов(чисел, которые читаются одинаково слева направо и справа налево).
Помогите решить пожалуйста, учитель бьется цветочком!
Составьте программу вычисления количества трехзначных чисел-палиндромов(чисел, которые читаются одинаково слева направо и справа налево).
Ответ(ы) на вопрос:
uses crt;
var e,d,s,i,k:integer;
begin
k:=0;
for i:=100 to 999 do
begin
e:=i mod 10;
d:=(i div 10)mod 10;
s:=i div 100;
if (e=s) or ((e=d) and (e=s)) then inc(k);
end;
writeln(k);
end.
Не нашли ответ?
Похожие вопросы