Помогите с Информатикой пожалуйста. №1 Напишите программу ,которая в последовательности целых чисел определяет кол-во чисел, оканчивающихся на 5. Программа получает на вход одномерный массив из 20 случайных чисел в диапазоне зн...

Помогите с Информатикой пожалуйста. №1 Напишите программу ,которая в последовательности целых чисел определяет кол-во чисел, оканчивающихся на 5. Программа получает на вход одномерный массив из 20 случайных чисел в диапазоне значений от 100 до 200. Программа должна вывести одно число : кол-во чисел , оканчивающихся на 5 или вывести сообщение "Таких чисел нет".Ввод и вывод массива организовать при помощи процедуры. №2 Напишите программу ,которая в последовательности целых чисел определяет максимальное число ,кратное 3 .Программа получает на вход двухмерный массив из 40 случайных чисел в диапазоне значений от -100 до 100. Программа должна вывести одно число - максимальное число ,кратное 3 или вывести сообщение "Таких чисел нет'. Ввод и вывод массива организовать при помощи процедуры.
Гость
Ответ(ы) на вопрос:
Гость
1) //PascalABC.NET версия 3.2, сборка 1389 //Если программа не запускается, то обновите версию begin     var a := ArrRandomInteger(20, 100, 200);     Println(a);     var k := a.Count(x -> x mod 10 = 5);     Writeln((k = 0) ? 'Таких чисел нет' : k.ToString()); end. 2) //PascalABC.NET версия 3.2, сборка 1389 //Если программа не запускается, то обновите версию begin     var a := ArrRandomInteger(40, -100, 100);     Println(a);     var max := a.Count(x -> x mod 3 = 0);     if max <> 0 then         max := a.Where(x -> x mod 3 = 0).Max;     Writeln((max = 0) ? 'Таких чисел нет' : max.ToString()); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы