Помогите с Паскалем ABS. 1 дано пятизначное число. определить сумму второй и пятой цифры. 2 дано пятизначное число. Определить сумму второй и четвёртой цифрой. 3 написать программу в которой подсчитывается количество чётных ...
Помогите с Паскалем ABS.
1 дано пятизначное число. определить сумму второй и пятой цифры.
2 дано пятизначное число. Определить сумму второй и четвёртой цифрой.
3 написать программу в которой подсчитывается количество чётных чисел среди трёх, введёных с клавиатуры
Ответ(ы) на вопрос:
№2.
var a,b: integer;
beginreadln(a);
b:=a;
a:= (a div 10) mod 10;
b:= (b div 1000) mod 10;
writeln(b+a);
end.
№1.
var a,b: integer;
beginreadln(a);
b:=a;
a:= a mod 10;
b:= (b div 1000) mod 10;
writeln(b+a);
end.
№ 1-2
var x, t, f, l, sum, sum2: integer;
begin
write('Введите x: ');
readln(x);
if ( x < 10000 ) OR ( x > 99999 ) then
writeln('Ошибка. Число не пятизначное!')
else
begin
l := x mod 10;
t := (x div 1000 mod 10);
sum := l + t;
f := (x div 10 mod 10);
sum2 := t + f;
writeln('Сумма второй и последней цифры: ', sum);
writeln('Сумма второй и четвертой цифры: ', sum2);
end;
end.
№3
var a, b, c, rez: integer;
begin
write('Введите первое число: ');
readln(a);
write('Введите второе число: ');
readln(b);
write('Введите третье число: ');
readln(c);
rez := 0;
if a mod 2 = 0 then inc(rez);
if b mod 2 = 0 then inc(rez);
if c mod 2 = 0 then inc(rez);
writeln('Количество четных чисел: ', rez);
end.
Не нашли ответ?
Похожие вопросы