Помогите с паскалем пожалуйста!! Дано натуральное число n. Составьте программу, которая определяет, сколько цифр содержится в числе n.
Помогите с паскалем пожалуйста!!
Дано натуральное число n. Составьте программу, которая определяет, сколько цифр содержится в числе n.
Ответ(ы) на вопрос:
program acab;
var n:real;
i:integer;
begin
read(n);
i:=0;
repeat
n:=n/10;
i:=i+1;
until abs(n)<1;
writeln(i);
end.
Не нашли ответ?
Похожие вопросы