Помогите с задачей, необходимо написать программу по данной блок схеме.программу на языке паскаль

Помогите с задачей, необходимо написать программу по данной блок схеме. программу на языке паскаль
Гость
Ответ(ы) на вопрос:
Гость
var   a,b,c,k:integer; begin   Read(a,b,c);   k:=1;   repeat     b:=2*b;     a:=a-b div 2;     if a<=0 then Writeln('Черт разорен')     else     begin       a:=a+c;       b:=b-c;       if b<=0 then Writeln('Крестьянин разорен')       else k:=k+1     end   until (a<=0) or (b<=0);   Writeln(k) end.
Гость
var a,b,c:real; k:integer; begin readln(a,b,c); k:=1; repeat b:=b*2; a:=a-b/2; if a<=0   then writeln('Чёрт разорён')  else begin       a:=a+c;       b:=b-c;       if b<=0 then writeln('Мужик разорён')               else k:=k+1;       end; until (a<=0)or(b<=0); writeln(k); end. Пример: 15 12 4 Чёрт разорён 2
Не нашли ответ?
Ответить на вопрос
Похожие вопросы