Помогите с задачками в паскале. Даны три положительных числа а, в, с. Проверить будут ли они сторонами треугольника. Если да то вычислить площадь это...
Помогите с задачками в паскале. Даны три положительных числа а, в, с. Проверить будут ли они сторонами треугольника. Если да то вычислить площадь этого треугольника. Даны два действительных положительных числа х и у. Арифметические действия над числами пронумерованы (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление). Составить программу, которая по выведенному номеру выполняет то или иное действие над числами.
Ответ(ы) на вопрос:
program task1;
var a, b, c, p, s :real;
begin
readln(a,b,c); if (a + b > c) and (a + c > b) and (b + c > a) then begin writeln('Могут быть сторонами треугольника'); p:= (a + b + c)/2; s:= sqrt( p * (p - a) * (p - b) * (p - c) ); writeln('Площадь равна ',s); end else writeln('Не могут быть сторонами треугольника');
end.
program task2;
var a, b, c :real; d :integer;
begin
write('Введите числа: '); readln(a,b); write('Введите номер действия: '); readln(d); case d of 1: c:= a + b; 2: c:= a - b; 3: c:= a * b; 4: c:= a / b; end; writeln(c);
end.
Не нашли ответ?
Похожие вопросы