Помогите составить программу для вычисления выражения на паскале
Помогите составить программу для вычисления выражения на паскале
Ответ(ы) на вопрос:
var
n,i:integer;
a,an,s:real;
begin
Write('Введите a и n: ');
Read(a,n);
s:=0;
an:=1;
for i:=0 to n do
begin
s:=s+(i+1)*an;
an:=an*a
end;
Writeln('Ответ ',s)
end.
Результат выполнения программы
Введите a и n: 2.2 30
Ответ 1036213351740.38
Не нашли ответ?
Похожие вопросы