Помогите составить программу вычисления в Pascal функции F(X), график которой имеет следующий вид: Получить значения функции при : 1)Х= -0,7; 2)Х= 0,3; 3)Х= 2,46; 4)Х= 3,6
Помогите составить программу вычисления в Pascal функции F(X), график которой имеет следующий вид:
Получить значения функции при : 1)Х= -0,7; 2)Х= 0,3; 3)Х= 2,46; 4)Х= 3,6
Ответ(ы) на вопрос:
Гость
[latex]\displaystyle F(x)=\left\{\begin{matrix} -x, & &x \leq 0\\ x,& &0\ \textless \ x \leq 1 \\ 1& &1\ \textless \ x \leq 3 \\ 4-x& &x\ \textgreater \ 3 \end{matrix}\right.[/latex]
function f(x:real):real;
begin
if x<=0 then f:=-x
else
if x<=1 then f:=x
else
if x<=3 then f:=1
else f:=4-x
end;
begin
Writeln('F(-0.7)=',f(-0.7));
Writeln('F(0.3)=',f(0.3));
Writeln('F(2.46)=',f(2.46));
Writeln('F(3.6)=',f(3.6))
end.
Результаты
F(-0.7)=0.7
F(0.3)=0.3
F(2.46)=1
F(3.6)=0.4
Не нашли ответ?
Похожие вопросы